使用c++ Problem Description 有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。 Input 输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。 Output 对于每个测试实例,输出插入新的元素后的数列。 Sample Input 3 3 1 2 4 0 0 Sample Output 1 2 3 4
时间: 2024-01-22 22:20:14 浏览: 124
对一个含有N整数的数组,使用堆排序让其由小到大输出
以下是使用C++的代码实现,每次读入一个数x后,从后往前遍历已有序的序列,找到第一个比x小的数的位置pos,然后将x插入到pos+1的位置即可。注意边界情况,当pos=-1时,说明x应该插入到序列的最前面。
```c++
#include <iostream>
using namespace std;
int main() {
int n, m;
while (cin >> n >> m && n != 0 && m != 0) {
int a[110];
for (int i = 0; i < n; i++) {
cin >> a[i];
}
int x;
cin >> x;
int pos = n-1;
while (pos >= 0 && a[pos] > x) {
a[pos+1] = a[pos];
pos--;
}
a[pos+1] = x;
for (int i = 0; i <= n; i++) {
cout << a[i];
if (i == n) cout << endl;
else cout << " ";
}
}
return 0;
}
```
阅读全文