现有两个字符串s1和s2,它们最多都只能包含255个字符。编写程序,将字符串s1中所有出现在字符串s2中的字符删去,然后输出s1。 【输入形式】 有两行输入。第一行输入为字符串s1,第二行输入为字符串s2 【输出形式
时间: 2024-05-12 20:16:05 浏览: 90
】输出为处理后的字符串s1。
代码示例:
```
#include <iostream>
#include <cstring>
using namespace std;
int main(){
string s1, s2;
getline(cin, s1);
getline(cin, s2);
int len = s1.length();
int len2 = s2.length();
for(int i = 0; i < len; i++){
for(int j = 0; j < len2; j++){
if(s1[i] == s2[j]){
s1.erase(i, 1);
len--; //删除字符后,字符串的长度减1
i--; //删除字符后,i需要往回退1
break;
}
}
}
cout << s1 << endl;
return 0;
}
```
输入示例:
```
hello world
old
```
输出示例:
```
he wr
```
相关问题
现有两个字符串s1和s2,它们最多都只能包含255个字符,编写程序,将字符串s1中所有出现在字符串s2中的字符删去,然后输出s1
要编写一个程序,首先你需要遍历字符串s2,检查其中的每个字符是否也在s1中。如果是,则从s1中移除该字符。这里提供了一个简单的C语言代码示例:
```c
#include <stdio.h>
#include <string.h>
// 函数用于删除s1中的s2中存在的字符
void removeChars(char *s1, char *s2) {
int i, j;
for (i = 0; s2[i] != '\0'; i++) {
// 对于s2中的每个字符
for (j = 0; s1[j] != '\0' && s1[j] != s2[i]; j++) {} // 如果s1中的字符不是s2中的,移动指针
if (s1[j] == s2[i]) { // 如果找到了匹配的字符,跳过该位置
memmove(&s1[j], &s1[j+1], strlen(s1) - 1] = '\0'; // 更新字符串长度
}
}
}
int main() {
char s1[256], s2[256];
printf("Enter string s1: ");
fgets(s1, sizeof(s1), stdin);
s1[strcspn(s1, "\n")] = '\0'; // 去掉换行符
printf("Enter string s2: ");
fgets(s2, sizeof(s2), stdin);
s2[strcspn(s2, "\n")] = '\0'; // 去掉换行符
removeChars(s1, s2);
printf("String after removing characters from s2: %s\n", s1);
return 0;
}
```
在这个程序中,`removeChars`函数使用了`memmove`函数来移动字符串中的字符,避免直接修改数组可能导致的数据不连续。`main`函数中获取用户输入并调用这个函数。
现有两个字符串s1和s2,它们最多都只能包含255个字符。编写程序,将字符串s1中所有出现在字符串s2中的字符删去,然后输出s1
的剩余字符。
这道题目可以使用哈希表来解决。具体步骤如下:
1. 新建一个数组或哈希表,用来记录字符串s2中出现的字符。
2. 遍历字符串s2,对于每一个字符,将对应的数组或哈希表位置上的值设置为1或true。
3. 遍历字符串s1,对于每一个字符,判断其在数组或哈希表中的位置上的值是否为1或true。如果是,说明这个字符在字符串s2中也出现过,可以删除;如果不是,则说明这个字符在字符串s2中没有出现过,需要保留。
4. 将剩余字符拼接起来,输出即可。
具体实现可以参考以下代码:
```python
s1 = "abcdefg"
s2 = "cdehij"
# 建立哈希表,记录字符串s2中出现的字符
s2_map = {}
for char in s2:
s2_map[char] = True
# 遍历字符串s1,判断每个字符是否需要删除
new_s1 = ""
for char in s1:
if char not in s2_map:
new_s1 += char
# 输出剩余字符
print(new_s1) # 输出为: abfg
```
阅读全文