C语言实现:【问题描述】 给定一个字符串,找到它的第一个不重复的字符,并返回它的索引。如果不存在,则返回 -1。 约束条件: (1) 0<=S.length<=300000 (2) 字符串中只包含小写字母 【输入形式】 输入一个字符串 【输出形式】 输出索引对应数字 【样例输入1】 leetcode 【样例输出1】 0 【样例输入2】 loveleetcode 【样例输出2】 2
时间: 2024-03-03 07:49:23 浏览: 106
C语言写的一些字符串处理函数,包括连接,查找重复字符和获取字符串长度
5星 · 资源好评率100%
以下是 C 语言实现的代码:
```c
#include <stdio.h>
#include <string.h>
int firstUniqChar(char* s) {
int len = strlen(s);
int freq[26] = {0};
for (int i = 0; i < len; i++) {
freq[s[i] - 'a']++;
}
for (int i = 0; i < len; i++) {
if (freq[s[i] - 'a'] == 1) {
return i;
}
}
return -1;
}
int main() {
char s[300001];
scanf("%s", s);
printf("%d", firstUniqChar(s));
return 0;
}
```
该算法的思路是使用哈希表记录每个字符出现的次数,然后再遍历一遍字符串查找第一个出现次数为 1 的字符。时间复杂度为 $O(n)$,其中 $n$ 为字符串长度。
阅读全文