编写程序,对于给定的字符串,用指定字符替换该字符串中的数字字符。 输入样例: abc0AB9 $ 输出样例: abc$AB$的C语言
时间: 2024-02-28 11:52:10 浏览: 185
字符串替换C程序
可以使用循环遍历字符串中的每一个字符,判断是否为数字字符,若是则替换成指定字符,否则保留原字符。下面是一个示例代码:
```c
#include <stdio.h>
int main() {
char str[100], replace;
printf("请输入字符串:");
scanf("%s", str);
printf("请输入替换字符:");
scanf(" %c", &replace); // 注意要在 %c 前面加一个空格,避免读入上一次输入时留下的回车符
for (int i = 0; str[i] != '\0'; i++) {
if (str[i] >= '0' && str[i] <= '9') {
str[i] = replace;
}
}
printf("替换后的字符串:%s\n", str);
return 0;
}
```
输入样例:
```
请输入字符串:abc0AB9
请输入替换字符:$
```
输出样例:
```
替换后的字符串:abc$AB$
```
阅读全文