本题要求使用 Collection 类的 Collections.max() 来获取向量的最大元素,并输出结果。 样例输入 3 5 2 1 6 7 样例输出 7
时间: 2023-12-03 10:43:11 浏览: 82
好的,可以使用以下代码实现:
```java
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
List<Integer> list = new ArrayList<>();
for (int i = 0; i < n; i++) {
int num = sc.nextInt();
list.add(num);
}
int max = Collections.max(list);
System.out.println(max);
}
}
```
输入时,先读入向量的长度 n,然后使用一个 ArrayList 存储向量的元素。循环读入每个元素后,使用 Collections.max() 方法获取最大值并输出即可。
阅读全文