c++输入一个字符串和一个字符,查找并输出字符在字符串中首次出现的位置,如果没有则输出-1
时间: 2024-05-05 10:21:07 浏览: 122
以下是使用C++实现的代码:
```c++
#include <iostream>
#include <string>
using namespace std;
int main() {
string str;
char c;
cout << "请输入一个字符串: ";
getline(cin, str);
cout << "请输入一个字符: ";
cin >> c;
int pos = str.find(c);
if (pos == -1) {
cout << "该字符没有在字符串中出现过" << endl;
} else {
cout << "该字符在字符串中首次出现的位置为: " << pos << endl;
}
return 0;
}
```
运行结果:
```
请输入一个字符串: hello world
请输入一个字符: o
该字符在字符串中首次出现的位置为: 4
```
相关问题
c++ 输入一个字符串和一个字符,查找并输出字符在字符串中首次出现的位置,如果没有则输出-1。
可以使用C++标准库中的`string`类和`find()`函数来实现。具体方法如下:
```c++
#include <iostream>
#include <string>
using namespace std;
int main() {
string str;
char ch;
int pos;
// 输入字符串和字符
cout << "请输入一个字符串: ";
getline(cin, str); // 读入整行字符串
cout << "请输入一个字符: ";
cin >> ch;
// 查找字符在字符串中的位置
pos = str.find(ch);
// 输出结果
if (pos == string::npos) { // 如果没有找到
cout << "-1" << endl;
} else { // 如果找到了
cout << "字符" << ch << "在字符串\"" << str << "\"中首次出现的位置为: " << pos << endl;
}
return 0;
}
```
输入样例:
```
请输入一个字符串: hello world
请输入一个字符: o
```
输出样例:
```
字符o在字符串"hello world"中首次出现的位置为: 4
```
C++程序设计输入一个字符串和一个字符,查找并输出字符在字符串中首次出现的位置,如果没有则输出-1
下面是一个用 C++ 实现的例子:
```cpp
#include <iostream>
#include <string>
using namespace std;
int main() {
string str;
char ch;
cout << "请输入一个字符串:";
getline(cin, str);
cout << "请输入一个字符:";
cin >> ch;
int pos = str.find(ch);
if (pos == string::npos) {
cout << "-1" << endl;
} else {
cout << pos << endl;
}
return 0;
}
```
运行程序后,会提示用户输入一个字符串和一个字符,然后查找并输出字符在字符串中首次出现的位置。如果没有找到该字符,则输出-1。例如,输入字符串 "hello world" 和字符 'w',则输出结果为 6。如果输入字符串 "hello world" 和字符 'z',则输出结果为 -1。
阅读全文