输入3个整数,利用指针和函数相关知识将数字按由小到大顺序输出
时间: 2024-01-08 15:15:08 浏览: 113
好的,以下是代码实现:
```c
#include <stdio.h>
void sort(int *a, int *b, int *c) {
int temp;
if (*a > *b) {
temp = *a;
*a = *b;
*b = temp;
}
if (*a > *c) {
temp = *a;
*a = *c;
*c = temp;
}
if (*b > *c) {
temp = *b;
*b = *c;
*c = temp;
}
}
int main() {
int a, b, c;
printf("请输入三个整数:");
scanf("%d%d%d", &a, &b, &c);
sort(&a, &b, &c);
printf("从小到大排列为:%d %d %d\n", a, b, c);
return 0;
}
```
输出结果:
```
请输入三个整数:20 10 30
从小到大排列为:10 20 30
```
这段代码中,sort函数接收三个指针参数,分别指向输入的三个整数。在函数内部,使用了冒泡排序的思想,将三个整数按由小到大的顺序排序。最后在主函数中调用sort函数,并传入三个整数的地址,并输出结果。
相关问题
用c语言顺序输出 输入3个整数,利用指针和函数相关知识将数字按由小到大顺序输出 输入说明: 3个整数 输入说明: 由小到大顺序输出 输入示例: 1 2 3 输出示例: 1 2 3
好的,下面是代码示例:
```c
#include <stdio.h>
void sort(int *a, int *b, int *c);
int main() {
int a, b, c;
printf("请输入三个整数:");
scanf("%d %d %d", &a, &b, &c);
sort(&a, &b, &c);
printf("%d %d %d", a, b, c);
return 0;
}
void sort(int *a, int *b, int *c) {
int temp;
if (*a > *b) {
temp = *a;
*a = *b;
*b = temp;
}
if (*a > *c) {
temp = *a;
*a = *c;
*c = temp;
}
if (*b > *c) {
temp = *b;
*b = *c;
*c = temp;
}
}
```
首先,我们定义了一个 `sort` 函数,用于将三个整数按从小到大的顺序排序。在 `main` 函数中,我们先输入三个整数,然后调用 `sort` 函数进行排序,最后输出排序后的结果。
在 `sort` 函数中,我们使用了指针来操作三个整数。我们通过 `a`、`b`、`c` 三个指针来访问这三个整数的值,并通过比较大小来进行排序。最终,`a` 指向的整数最小,`b` 指向的整数次小,`c` 指向的整数最大。
c++输入3个整数,利用指针和函数,按由小到大的顺序输出
以下是使用指针和函数按由小到大顺序输出3个整数的C++代码:
```cpp
#include <iostream>
using namespace std;
void sort(int *a, int *b, int *c) {
if (*a > *b) {
swap(*a, *b);
}
if (*a > *c) {
swap(*a, *c);
}
if (*b > *c) {
swap(*b, *c);
}
}
int main() {
int a,, c;
cin >> a >> b >> c;
sort(&a, &b, &c);
cout << a << " " << b << " " << c << endl;
return 0;
}
```
阅读全文