用C++输入一个字符串,将其中的小写字母修改为大写字母,输出该字符串。
时间: 2024-02-06 09:09:35 浏览: 87
可以使用C++中的标准库函数 `toupper` 来将小写字母转换为大写字母,以下是一个示例代码:
```c++
#include <iostream>
#include <cstring>
#include <cctype>
using namespace std;
int main()
{
char str[100];
cout << "请输入一个字符串: ";
cin >> str;
int len = strlen(str);
for (int i = 0; i < len; i++) {
if (islower(str[i])) { // 判断是否为小写字母
str[i] = toupper(str[i]); // 转换为大写字母
}
}
cout << "转换后的字符串为: " << str << endl;
return 0;
}
```
输入示例:
```
请输入一个字符串: Hello, world!
```
输出示例:
```
转换后的字符串为: HELLO, WORLD!
```
相关问题
输入一个字符串,将其中的小写字母转换为大写字母后输出的代码用c++
以下是将输入字符串中的小写字母转换为大写字母后输出的C++代码:
```c++
#include<iostream>
#include<string>
using namespace std;
int main() {
string s;
getline(cin, s); // 接收输入的字符串
for (int i = 0; i < s.size(); i++) {
if (s[i] >= 'a' && s[i] <= 'z') { // 判断字符是否为小写字母
s[i] -= 32; // 转换为大写字母
}
}
cout << s << endl; // 输出转换后的字符串
return 0;
}
```
注意,这里使用了ASCII码表中大写字母和小写字母的编码值之间的差值为32的性质,将小写字母转换为大写字母。
将字符串中的小写字母转换成大写字母 题目描述 给定一个字符串,将其中所有的小写字母转换成大写字母。 输入格式 输入一行,包含一个字符串(长度不超过100,可能包含空格)。 输出格式 输出转换后的字符串。使用c++
可以使用C语言中的标准库函数`toupper`来将小写字母转换成大写字母。具体方法如下:
```c
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[101];
fgets(str, 101, stdin); // 读入字符串
for (int i = 0; str[i] != '\0'; i++)
{
if (islower(str[i])) // 判断是否为小写字母
printf("%c", toupper(str[i])); // 转换成大写字母并输出
else
printf("%c", str[i]); // 否则直接输出
}
return 0;
}
```
其中,`islower`函数用于判断是否为小写字母,`toupper`函数用于将小写字母转换成大写字母。
阅读全文