描述 输入一串字符,请你统计出现次数最少和最多的字符以及对应的出现次数 输入 一行,一个字符串,只包含小写字母,长度不超过300 输出 两行, 第一行为出现次数最少的字符和次数,用空格隔开 第二行为出现次数最多的字符和次数,用空格隔开 说明:如果有相同的最少/多出现次数情况,按照ASC||值从小到大的顺序 输入样例 1 cbdddaaa 输出样例1 b 1 a 3 c++ 代码
时间: 2024-04-11 16:27:06 浏览: 76
```cpp
#include <iostream>
#include <string>
#include <map>
int main() {
std::string str;
std::cin >> str;
std::map<char, int> countMap;
// 统计每个字符出现的次数
for (char c : str) {
countMap[c]++;
}
// 找到出现次数最少和最多的字符及其次数
char minChar = '\0', maxChar = '\0';
int minCount = INT_MAX, maxCount = 0;
for (auto it = countMap.begin(); it != countMap.end(); ++it) {
if (it->second < minCount) {
minCount = it->second;
minChar = it->first;
}
if (it->second > maxCount) {
maxCount = it->second;
maxChar = it->first;
}
}
// 输出结果
std::cout << minChar << " " << minCount << std::endl;
std::cout << maxChar << " " << maxCount << std::endl;
return 0;
}
```
注意:本代码是用 C++ 编写的,可以在 C++ 编译器中运行。
阅读全文