C语言顺序读入浮点1、整数、字符、浮点数2,在按照字符、整数、浮点数1浮点数2的顺序输出,浮点保留小数点后两位
时间: 2023-12-27 22:03:02 浏览: 91
```c
#include <stdio.h>
int main() {
float f1, f2;
int i;
char c;
// 读入四个变量
scanf("%f %d %c %f", &f1, &i, &c, &f2);
// 输出四个变量
printf("%c %d %.2f %.2f", c, i, f1, f2);
return 0;
}
```
相关问题
顺序读入浮点1、整数、字符、浮点数2,在按照字符、整数、浮点数1浮点数2的顺序输出,浮点保留小数点后两位
示例输入:
```
3.14
100
a
2.718
```
示例输出:
```
a 100 3.14 2.72
```
代码实现:
```python
# 读入浮点1、整数、字符、浮点数2
f1 = float(input())
n = int(input())
c = input()
f2 = float(input())
# 输出
print(c, n, format(f1, '.2f'), format(f2, '.2f'))
```
C语言编写程序,顺序读入浮点数1、整数、字符、浮点数2,再按照字符、整数、浮点数1、浮点数2的顺序输出,要求输入在一行中顺序给出浮点数1、整数、字符、浮点数2,其间以1个空格分隔,在一行中按照字符、整数、浮点数1、浮点数2的顺序输出,其中浮点数保留小数点后2位。
```c
#include<stdio.h>
int main()
{
float f1,f2;
int n;
char c;
scanf("%f %d %c %f",&f1,&n,&c,&f2);
printf("%c %d %.2f %.2f",c,n,f1,f2);
return 0;
}
```
阅读全文