C 把一个字符串中的大写字母改成小写字母,其他字符不变。 输入格式: 在 一行中输入长度小于20的字符串。在字符串中不要出现换行符,空格,制表符。 输出格式: 直接输出变化后的字符串。
时间: 2024-03-21 13:39:55 浏览: 78
下面是 C 语言的程序实现:
```c
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[20];
int i;
// 读入字符串
scanf("%s", str);
// 将大写字母改成小写字母
for (i = 0; str[i] != '\0'; i++) {
if (isupper(str[i])) {
str[i] = tolower(str[i]);
}
}
// 输出字符串
printf("%s", str);
return 0;
}
```
这个程序通过 `isupper` 函数和 `tolower` 函数实现了将大写字母改成小写字母的功能。
相关问题
把字符串中的大写字母改成小写字母,其他字符不变。 输入格式: 输入一个长度不超过20的包含大小写母和数字的字符串。 输出格式: 输出大写字母改成小写字母后的字符串,用c语言并且可以输入字符
以下是 C 语言代码实现:
```c
#include <stdio.h>
#include <ctype.h>
int main() {
char str[21];
scanf("%20s", str); // 读入字符串,最多读入 20 个字符
for (int i = 0; str[i] != '\0'; i++) {
if (isupper(str[i])) { // 如果是大写字母
str[i] = tolower(str[i]); // 转换成小写字母
}
}
printf("%s\n", str); // 输出转换后的字符串
return 0;
}
```
代码说明:
1. 首先定义一个字符数组 `str`,用于存储输入的字符串。
2. 使用 `scanf` 函数读入字符串,其中 `%20s` 限制最多读入 20 个字符。
3. 使用 `for` 循环遍历字符串,如果当前字符是大写字母,则使用 `tolower` 函数将其转换成小写字母。
4. 最后使用 `printf` 函数输出转换后的字符串。注意,需要在字符串后面加上换行符 `\n`。
示例输入:
```
HeLLo, WOrld!
```
示例输出:
```
hello, world!
```
c语言把一个字符串中的大写字母改成小写字母,其他字符不变。代码
可以使用以下的 C 语言代码来实现:
```
#include <stdio.h>
#include <ctype.h>
#include <string.h>
int main() {
char str[100];
printf("请输入一个字符串:\n");
fgets(str, 100, stdin); // 从标准输入读入字符串
for (int i = 0; i < strlen(str); i++) {
if (isupper(str[i])) { // 判断当前字符是否为大写字母
str[i] = tolower(str[i]); // 转换为小写字母
}
}
printf("转换后的字符串为:%s\n", str);
return 0;
}
```
在这个程序中,我们首先通过 `fgets()` 函数从标准输入读入一个字符串,并存储到 `str` 数组中。然后使用一个 `for` 循环遍历字符串中的每一个字符,如果当前字符是大写字母,就使用 `tolower()` 函数将其转换为小写字母。最后再使用 `printf()` 函数将转换后的字符串输出到屏幕上。
阅读全文