本题要求编写程序,对一个以“#”结束的字符串,将其小写字母全部转换成大写字母,把大写字母全部转换成小写字母,其他字符不变输出。 输入格式: 输入为一个以“#”结束的字符串(不超过30个字符)。 输出格式: 在一行中输出大小写转换后的结果字符串。 输入样例: Hello World! 123# 输出样例: hELLO wORLD! 123 代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MB C (gcc) 1
时间: 2024-03-27 20:36:15 浏览: 20
一个对字符串处理的程序,要求能够识别字符串中大写字母、小写字母以及数字的个数并输出,识别“L”、“o”、“v”、“e”四个字符的
5星 · 资源好评率100%
```c
#include <stdio.h>
#include <string.h>
int main() {
char s[31];
fgets(s, 31, stdin);
int len = strlen(s);
for (int i = 0; i < len; i++)
if (s[i] >= 'a' && s[i] <= 'z')
printf("%c", s[i] - 'a' + 'A');
else if (s[i] >= 'A' && s[i] <= 'Z')
printf("%c", s[i] - 'A' + 'a');
else if (s[i] == '#')
break;
else
printf("%c", s[i]);
return 0;
}
```
阅读全文