求一批整数中出现最多的数字。输入一个正整数n(1<n≤1000),再输入n个整数,分析 每个整数的每一位数字,求出现次数最多的各位数字c语言。
时间: 2024-06-13 07:07:48 浏览: 165
以下是C语言实现求一批整数中出现最多的数字的代码:
```c
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n, num, max_num = 0, max_count = 0;
int count[10] = {0}; // 数字0~9出现的次数
printf("请输入正整数n:");
scanf("%d", &n);
for (int i = 0; i < n; i++) {
printf("请输入第%d个整数:", i + 1);
scanf("%d", &num);
while (num > 0) {
int digit = num % 10;
count[digit]++;
num /= 10;
}
}
for (int i = 0; i < 10; i++) {
if (count[i] > max_count) {
max_count = count[i];
max_num = i;
}
}
printf("出现次数最多的数字是:%d,出现了%d次。\n", max_num, max_count);
return 0;
}
```
相关问题
求一批整数中出现最多的数字。输入一个正整数n(1<n≤1000),再输入n个整数,分析每个整数的每一位数字,求出现次数最多的数字。
以下是Python实现求一批整数中出现最多的数字的代码:
```python
n = int(input("请输入正整数n:"))
nums = input("请输入n个整数,用空格隔开:").split()
# 统计每个数字出现的次数
count = {}
for num in nums:
for digit in num:
if digit in count:
count[digit] += 1
else:
count[digit] = 1
# 找出出现次数最多的数字
max_count = 0
max_digit = ''
for digit, c in count.items():
if c > max_count:
max_count = c
max_digit = digit
print("出现次数最多的数字是:", max_digit)
```
输入样例:
```
请输入正整数n:5
请输入n个整数,用空格隔开:123 456 789 12345 67890
```
输出样例:
```
出现次数最多的数字是:3
```
c语言求一批整数中出现最多的数字。输入一个正整数 n (1<n≤1000),再输入 n 个整数,分析 每个整数的每一位数字,求出现次数最多的各位数字。
以下是C语言求一批整数中出现最多的数字的代码实现:
```c
#include <stdio.h>
#include <string.h>
int main()
{
int n, num, max_count = 0, max_num[10] = {0};
scanf("%d", &n);
for (int i = 0; i < n; i++)
{
scanf("%d", &num);
char str[15];
sprintf(str, "%d", num);
int len = strlen(str);
int count[10] = {0};
for (int j = 0; j < len; j++)
{
count[str[j] - '0']++;
}
for (int j = 0; j < 10; j++)
{
if (count[j] > max_count)
{
max_count = count[j];
memset(max_num, 0, sizeof(max_num));
max_num[j] = 1;
}
else if (count[j] == max_count)
{
max_num[j] = 1;
}
}
}
for (int i = 0; i < 10; i++)
{
if (max_num[i])
{
printf("%d ", i);
}
}
return 0;
}
```
阅读全文