【问题描述】编写程序,打印一个学生的成绩数组,该数组中由若干个学生的数据记录,每个记录包括 num、name、score[3],其中num表示学号,name表示姓名,score[3]表示三门课的成绩(假设成绩为整数),用主函数输入这些记录,然后输出这些记录。 【输入形式】第一行输入学生数n,接下来的n行,每行输入学生的学号、姓名和成绩,以空格分开 【输出形式】每行输出一个学生的信息 【样例输入】 3 101 张三丰 76 56 90 102 李明 56 87 76 103 刘军 87 76 81 【样例输出】 101 张三丰 76 56 90 102 李明 56 87 76 103 刘军 87 76 81
时间: 2024-02-15 11:05:55 浏览: 85
以下是C++代码实现:
```c++
#include <iostream>
#include <vector>
using namespace std;
struct Student {
string num; // 学号
string name; // 姓名
int score[3]; // 成绩
};
int main() {
int n;
cin >> n; // 输入学生数目
vector<Student> students(n); // 定义学生数组
// 循环输入每个学生的信息
for (int i = 0; i < n; i++) {
cin >> students[i].num >> students[i].name;
for (int j = 0; j < 3; j++) {
cin >> students[i].score[j];
}
}
// 循环输出每个学生的信息
for (int i = 0; i < n; i++) {
cout << students[i].num << " " << students[i].name << " ";
for (int j = 0; j < 3; j++) {
cout << students[i].score[j] << " ";
}
cout << endl;
}
return 0;
}
```
输入示例:
```
3
101 张三丰 76 56 90
102 李明 56 87 76
103 刘军 87 76 81
```
输出示例:
```
101 张三丰 76 56 90
102 李明 56 87 76
103 刘军 87 76 81
```
阅读全文