C语言中输入一行字符,分别统计出其中英文字母、数字、空格和其他字符的个数。 编程要求 输入 一行字符。 输出 统计每种字符的个数值。 样例输入: aklsjflj123 sadf918u324 asdf91u32oasdf/.';123 样例输出: 23 16 2 4
时间: 2024-03-10 10:49:54 浏览: 44
好的,请将下面的代码复制到你的编译器中试试:
```c++
#include <stdio.h>
int main() {
char str[1000];
fgets(str, sizeof(str), stdin);
int letter = 0, number = 0, space = 0, other = 0;
for (int i = 0; str[i] != '\0'; i++) {
if ((str[i] >= 'a' && str[i] <= 'z') || (str[i] >= 'A' && str[i] <= 'Z')) {
letter++;
} else if (str[i] >= '0' && str[i] <= '9') {
number++;
} else if (str[i] == ' ') {
space++;
} else {
other++;
}
}
printf("%d %d %d %d", letter, number, space , other);
return 0;
}
```
输入样例:
```
aklsjflj123 sadf918u324 asdf91u32oasdf/.';123
```
输出样例:
```
23 16 2 4
```
注意:以上代码要在 C 语言环境下运行。
相关问题
C语言编程输入一行字符分别统计出其中英文字母,空格,数字和其他字符的个数
好的,我可以回答这个问题。请看下面的代码:
```
#include <stdio.h>
#include <ctype.h>
int main() {
char input[100];
int letters = 0;
int spaces = 0;
int digits = 0;
int others = 0;
printf("请输入一行字符:\n");
fgets(input, 100, stdin);
for (int i = 0; input[i] != '\0'; i++) {
if (isalpha(input[i])) {
letters++;
} else if (isspace(input[i])) {
spaces++;
} else if (isdigit(input[i])) {
digits++;
} else {
others++;
}
}
printf("字符数:%d\n英文字母数:%d\n空格数:%d\n数字数:%d\n其他字符数:%d\n", letters + spaces + digits + others, letters, spaces, digits, others);
return 0;
}
```
这个程序使用了 `fgets()` 函数来读取一行字符,然后使用 `isalpha()`、`isspace()` 和 `isdigit()` 函数来判断每个字符的类型。最后统计出各种类型字符的数量并输出。
输入一行字符分别统计出其中英文字母数字空格和其他字符的个数,如何用C语言实现?
在C语言中,你可以通过遍历输入字符串并使用相应的条件判断来统计字母、数字、空格和其他字符的数量。下面是一个简单的示例程序:
```c
#include <stdio.h>
#include <ctype.h> // 包含ctype.h头文件,用于处理字符类型
int main() {
char input[100];
int alpha_count = 0; // 字母计数
int digit_count = 0; // 数字计数
int space_count = 0; // 空格计数
int other_count = 0; // 其他字符计数
printf("请输入一行字符: ");
fgets(input, sizeof(input), stdin); // 从标准输入读取一行字符
for (int i = 0; input[i] != '\0'; i++) { // 遍历字符串
if (isalpha(input[i])) { // 检查是否为字母
alpha_count++;
} else if (isdigit(input[i])) { // 检查是否为数字
digit_count++;
} else if (input[i] == ' ') { // 检查是否为空格
space_count++;
} else { // 其他字符
other_count++;
}
}
printf("\n字母: %d\n", alpha_count);
printf("数字: %d\n", digit_count);
printf("空格: %d\n", space_count);
printf("其他字符: %d\n", other_count);
return 0;
}
```
这个程序首先定义了四个整数变量分别对应四种类型的字符计数,然后通过`fgets()`函数获取用户输入的字符串。接下来,它遍历字符串并对每个字符进行检查:如果是字母、数字或空格,就相应地增加计数;如果不是这三种情况,就将它们归类为其他字符。
最后,程序打印出每种字符类型的计数。
阅读全文