请用C语言编写如下程序:定义一个80个元素的字符数组,输入一串字符存放其中,统计每个数字字符的个数按数字字符的顺序存放在 int c[10]的数组中。并输出结果。【输入样例】 abc123450987JFK012【输出样例】 0:2(字符串中含有2个0) 1:2 2:2 3:1 4:1 5:1 6:0 7:1 8:1 9:1
时间: 2023-06-08 11:04:37 浏览: 57
以下是用C语言编写的程序:
```c
#include <stdio.h>
int main() {
char str[81]; // 定义一个80个元素的字符数组
int c[10] = {0}; // 定义一个10个元素的整型数组,初始值为0
printf("请输入一个字符串(长度不超过80):");
scanf("%s", str);
// 遍历字符串的每个字符,如果是数字字符,则在对应的计数器上加1
for (int i = 0; str[i] != '\0'; i++) {
if (str[i] >= '0' && str[i] <= '9') {
c[str[i] - '0']++;
}
}
// 输出结果
for (int i = 0; i < 10; i++) {
printf("%d:%d(字符串中含有%d个%d)\n", i, c[i], c[i], i);
}
return 0;
}
```
示例输出:
```
请输入一个字符串(长度不超过80):abc123450987JFK012
0:2(字符串中含有2个0)
1:2(字符串中含有2个1)
2:2(字符串中含有2个2)
3:1(字符串中含有1个3)
4:1(字符串中含有1个4)
5:1(字符串中含有1个5)
6:0(字符串中含有0个6)
7:1(字符串中含有1个7)
8:1(字符串中含有1个8)
9:1(字符串中含有1个9)
```
阅读全文