6-15 判断两个账户是否相同 分数 12 作者 邱颖豫 单位 许昌学院 根据裁判程序的内容,补全Account类中的方法。 裁判测试程序样例: import java.util.Scanner; class Account{ int id; String name; double balance; /*你的代码填写在这里*/ } public class Main { public static void main(String[] args) { Scanner sc = new Scanner(System.in); Account a = new Account(sc.nextInt() , sc.next()); System.out.println(a); Account b = new Account(sc.nextInt() , sc.next(),1000); System.out.println(b); System.out.println(a.equals(b)); sc.close(); } } 输入样例1: 在这里给出一组输入。例如: 108 张明月 109 李向阳 输出样例1: 在这里给出相应的输出。例如: 帐号:108 姓名:张明月 余额:0.0 帐号:109 姓名:李向阳 余额:1000.0 false 输入样例2: 在这里给出一组输入。例如: 108 张明月 108 李向阳 输出样例2: 在这里给出相应的输出。例如: 帐号:108 姓名:张明月 余额:0.0 帐号:108 姓名:李向阳 余额:1000.0 true 代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MB
时间: 2024-02-14 09:20:27 浏览: 133
补全代码如下:
```java
import java.util.Objects;
class Account{
int id;
String name;
double balance;
public Account(int id, String name) {
this.id = id;
this.name = name;
}
public Account(int id, String name, double balance) {
this.id = id;
this.name = name;
this.balance = balance;
}
@Override
public String toString() {
return "帐号:" + id + " " + "姓名:" + name + " " + "余额:" + balance;
}
@Override
public boolean equals(Object o) {
if (this == o) return true;
if (o == null || getClass() != o.getClass()) return false;
Account account = (Account) o;
return id == account.id;
}
@Override
public int hashCode() {
return Objects.hash(id);
}
}
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
Account a = new Account(sc.nextInt(), sc.next());
System.out.println(a);
Account b = new Account(sc.nextInt(), sc.next(), 1000);
System.out.println(b);
System.out.println(a.equals(b));
sc.close();
}
}
```
阅读全文