编写函数重置两个变量的值,函数内部将两个值重置为两个变量原值的平均数(出现小数则四舍五入。) 要求:○1函数参数使用指针;○2函数参数使用引用。 输入格式:两个待重置的值 输出格式: 重置后的两个值 输入样例: 7 14 输出样例: 11 11
时间: 2023-04-04 13:00:26 浏览: 43
函数使用指针作为参数的实现方式如下:
```c
#include <stdio.h>
#include <math.h>
void resetByPointer(double *a, double *b) {
double avg = (*a + *b) / 2.;
*a = round(avg);
*b = round(avg);
}
int main() {
double a, b;
scanf("%lf %lf", &a, &b);
resetByPointer(&a, &b);
printf("%.lf %.lf", a, b);
return ;
}
```
函数使用引用作为参数的实现方式如下:
```c
#include <stdio.h>
#include <math.h>
void resetByReference(double &a, double &b) {
double avg = (a + b) / 2.;
a = round(avg);
b = round(avg);
}
int main() {
double a, b;
scanf("%lf %lf", &a, &b);
resetByReference(a, b);
printf("%.lf %.lf", a, b);
return ;
}
```
阅读全文