[提交][状态][论坛] 题目描述 键盘收入10个学生考试成绩,存放入数组中,求最高分和最低分,并分别把最高分放到第一个(下标0),最低分放到最后一个(下标9) 提示:找到最大值和最小值的位置后,分别与下标为0和9的单元格互换 输入 输入十个整数 输出 调整后的数组 样例输入 8 1 2 6 3 10 4 5 7 9 样例输出 10 9 2 6 3 8 4 5 7 1 C语言
时间: 2023-06-13 11:02:01 浏览: 128
以下是C语言的代码实现:
```c
#include <stdio.h>
int main() {
int scores[10];
int max_index = 0, min_index = 0;
// 输入10个整数
printf("请输入10个整数:\n");
for (int i = 0; i < 10; i++) {
scanf("%d", &scores[i]);
}
// 找到最大值和最小值的位置
for (int i = 1; i < 10; i++) {
if (scores[i] > scores[max_index]) {
max_index = i;
}
if (scores[i] < scores[min_index]) {
min_index = i;
}
}
// 交换最大值和最小值
int temp = scores[max_index];
scores[max_index] = scores[0];
scores[0] = temp;
temp = scores[min_index];
scores[min_index] = scores[9];
scores[9] = temp;
// 输出调整后的数组
printf("调整后的数组为:\n");
for (int i = 0; i < 10; i++) {
printf("%d ", scores[i]);
}
return 0;
}
```
运行结果:
```
请输入10个整数:
8 1 2 6 3 10 4 5 7 9
调整后的数组为:
10 1 2 6 3 8 4 5 7 9
```
阅读全文