找出给定字符串中的最长字符串。 【输入形式】空格分隔输入多个字符串(一次输入) 「输出形式1 所有最长字符串,空格陽开,输出顺字保持输入原顺序不变 【样例输入17 worild life is hello 【样例输出1] world hello 【样例说明】 所有字符串中最长的字符串有两个,”world'和"hello”
时间: 2024-03-24 16:39:39 浏览: 47
好的,这是一个很简单的字符串处理问题。我可以用 Python 语言为您提供解决方案,您可以在本地运行或者在在线的 Python 环境上测试。
代码如下:
```python
# 输入字符串
s = input().split()
# 找出最长字符串的长度
max_len = max(len(word) for word in s)
# 输出所有最长字符串
longest_words = [word for word in s if len(word) == max_len]
print(' '.join(longest_words))
```
您可以将以上代码复制到 Python 环境中运行,输入字符串后即可得到最长字符串。注意,代码中的 `input()` 函数是用于从命令行读取输入的,您可以根据实际情况调整输入方式。
阅读全文