用Java代码回答以下问题:问题描述:在听说美国肥胖流行之后,农夫约翰希望他的奶牛能够做更多的运动,因此他为了他的奶牛提交了马拉松申请,马拉松路线包括一系列农场对和它们之间的道路组成的路径。由于约翰希望奶牛尽可能的多运动,他想在地图上找到彼此距离最远的两个农场(距离是根据两个农场之间的道路的总长度来衡量的。)请帮助他确定这对最远的农场之间的距离。 输入格式:第一行是两个以空格符分隔的整数n和m;接下来的第二行到第m+1行,每行包含4个以空格分开的元素x,y,w和d来描述一条道路,其中x和y是一条长度为w的道路相连的两个农场的编号,d是字符N.E.S.或W,表示从x到y的道路的方向。 输出格式:给出最远的一对农场之间距离的整数。 输入样例: 7 6 1 6 13 E 6 3 9 E 3 5 7 S 4 1 3 N 2 4 20 W 4 7 2 S 输出样例: 52
时间: 2023-12-14 13:37:59 浏览: 113
poj 前5题的C 和java代码
```java
import java.util.*;
public class Main {
static int N = 10010, M = N * 2;
static int[] h = new int[N];
static int[] e = new int[M];
static int[] w = new int[M];
static int[] ne = new int[M];
static int idx = 0;
static int n, m;
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
n = scan.nextInt();
m = scan.nextInt();
Arrays.fill(h, -1);
for (int i = 0; i < m; i++) {
int a = scan.nextInt();
int b = scan.nextInt();
int c = scan.nextInt();
char d = scan.next().charAt(0);
add(a, b, c, d);
add(b, a, c, d);
}
int ans = 0;
for (int i = 1; i <= n; i++) {
ans = Math.max(ans, bfs(i));
}
System.out.println(ans);
}
private static int bfs(int u) {
int[] dist = new int[N];
Arrays.fill(dist, -1);
Queue<Integer> q = new LinkedList<>();
q.offer(u);
dist[u] = 0;
while (!q.isEmpty()) {
int t = q.poll();
for (int i = h[t]; i != -1; i = ne[i]) {
int j = e[i];
if (dist[j] == -1) {
dist[j] = dist[t] + w[i];
q.offer(j);
}
}
}
int res = 0;
for (int i = 1; i <= n; i++) {
if (dist[i] == -1) {
return -1;
}
res = Math.max(res, dist[i]);
}
return res;
}
private static void add(int a, int b, int c, char d) {
e[idx] = b;
w[idx] = c;
char[] direction = {'N', 'E', 'S', 'W'};
int index = 0;
for (int i = 0; i < 4; i++) {
if (d == direction[i]) {
index = i;
break;
}
}
if (index == 0) {
ne[idx] = h[a];
h[a] = idx++;
} else if (index == 1) {
ne[idx] = h[a];
h[a] = idx++;
} else if (index == 2) {
ne[idx] = h[a];
h[a] = idx++;
} else {
ne[idx] = h[a];
h[a] = idx++;
}
}
}
```
阅读全文