c语言 【问题描述】 输入n个字符串,输出其中最小的字符串。 【样例输入】 5 tool key about zoo sea 【样例输出】 about
时间: 2023-11-29 08:04:04 浏览: 83
【C语言代码实现】
```c
#include <stdio.h>
#include <string.h>
int main() {
int n;
scanf("%d", &n); // 输入字符串个数
char min_str[1000];
scanf("%s", min_str); // 先将第一个字符串作为最小值
for (int i = 1; i < n; i++) {
char s[1000];
scanf("%s", s);
if (strcmp(s, min_str) < 0) {
strcpy(min_str, s);
}
}
printf("%s\n", min_str);
return 0;
}
```
注意:这里使用了 `<string.h>` 库中的 `strcmp()` 和 `strcpy()` 函数,需要在编译时加上 `-lstring` 选项。
相关问题
【问题描述】 输入n个字符串,输出其中最小的字符串。 【样例输入】 5 tool key about zoo sea 【样例输出】 about
【Python代码实现】
```
n = int(input()) # 输入字符串个数
min_str = input() # 先将第一个字符串作为最小值
for i in range(n-1):
s = input()
if s < min_str:
min_str = s
print(min_str)
```
输出多个字符串中最小的字符串。 #include <stdio.h> #include <string.h> int main() { const char *st[] = {"bag", "good", "This", "are", "Zoo", "park"}; const char *smin; int i; smin=  1 分 ; for(i = 1; i < 6; i++){ if(strcmp(  1 分 ) < 0){ smin = st[i]; } }
完整的代码如下:
```c
#include <stdio.h>
#include <string.h>
int main() {
const char *st[] = {"bag", "good", "This", "are", "Zoo", "park"};
const char *smin;
int i;
smin = st[0];
for(i = 1; i < 6; i++){
if(strcmp(smin, st[i]) > 0){
smin = st[i];
}
}
printf("The smallest string is: %s\n", smin);
return 0;
}
```
在这段代码中,我们使用了一个字符串数组 `st` 来存储多个字符串,然后使用指针 `smin` 来指向当前的最小字符串。在循环中,我们使用 `strcmp()` 函数来比较 `smin` 和 `st[i]` 的大小关系,如果 `st[i]` 比 `smin` 更小,就将 `smin` 指向 `st[i]`。最后输出最小的字符串即可。
注意,在循环开始之前,我们需要将 `smin` 初始化为数组中的第一个字符串(即 `st[0]`),否则循环中的第一次比较会出错。
阅读全文