用c++编写函数deleteChar,用于删除字符串(传长不超过100)中指定的字符,将字符 串中与指定字符(非空格字符)相同的字符全部删除。
时间: 2023-03-15 20:19:41 浏览: 175
可以使用以下函数来实现:void deleteChar(char str[], char c)
{
int i = 0, j = 0;
while (str[i] != '\0')
{
if (str[i] != c)
{
str[j++] = str[i];
}
i++;
}
str[j] = '\0';
}
相关问题
3请编写 一个函数,能够实现删除字符串中指定的字符。函数原型如下: char* DeleteChar(char* str, char ch),其功能是把str所指向的字符串中的所包含ch字符删除,然后返回删除后的 123. 字符串。要求:在主函数中进行输入和输出。 输入说明: 输入占两行,第一行为待删除的字符串,第二行为需要删除的字符。 输出说明: 输出占一行, 即删除之后的字符串。
以下是实现题目要求的 C++ 代码:
```cpp
#include <iostream>
#include <cstring>
using namespace std;
char* DeleteChar(char* str, char ch)
{
int len = strlen(str);
int i, j;
for (i = 0, j = 0; i < len; i++)
{
if (str[i] != ch)
{
str[j++] = str[i];
}
}
str[j] = '\0';
return str;
}
int main()
{
char str[100], ch;
cin.getline(str, 100);
cin >> ch;
DeleteChar(str, ch);
cout << str << endl;
return 0;
}
```
函数 DeleteChar 的实现遍历字符串,如果字符不是待删除的字符,则将其拷贝到结果字符串中。最后将结果字符串末尾置为 '\0',并返回结果字符串。
在主函数中,先输入待删除的字符串,然后输入需要删除的字符。调用 DeleteChar 函数,输出删除之后的字符串即可。
用c++代码写出请编写一个函数,能够实现删除字符串中指定的字符。函数原型如下:char* DeleteChar(char*str,char ch),其功能是把str所指向的字符串中的所包含ch字符删除,然后返回删除后的字符串。要求:在主函数中进行输入和输出。输入说明: 输入占两行,第一行为待删除的字符串,第二行为需要删除的字符。输出说明: 输出占一行,即删除之后的字符串。【输入样例】 J#udge #not #fro#m a#ppear#anc#es # 答题详情 【输出样例】 联想应 Judge not from appearances.
以下是代码实现:
```cpp
#include <iostream>
#include <cstring>
using namespace std;
char* DeleteChar(char* str, char ch) {
char* p;
char* q;
p = q = str;
while (*q != '\0') {
if (*q != ch) {
*p++ = *q;
}
q++;
}
*p = '\0';
return str;
}
int main() {
char str[1000];
char ch;
cin.getline(str, 1000);
cin >> ch;
cout << DeleteChar(str, ch);
return 0;
}
```
输入样例:
```
J#udge #not #fro#m a#ppear#anc#es #
#
```
输出样例:
```
Judge not from appearances.
```
阅读全文