从键盘接收某工厂 三 名 保安 年 龄 兰 某 保: 安 年 龄 大子60 或者小于 18 时 【输入形式/箱 开 式】 正常:从键盘录入三个整效:56 45 35 输出:45 异常:从键盘录入三个整数:55-136 输出: Exception in thread "main" java.lang. Exception: age input error at Example02.main (Example02.java:10) 【样例输入】 77-134 【样例输出】 Exception in thread "main" java.lang. Exception: age input error at Example02.main(Example02.java:10) [样例说明〕无 {评分标准】测试用例正确得满分。 抛出 import java.util.Scanner; public class Example02 r public static void main(String[ args) throws Exception ( Scanner input=new Scanner(System.in); lintil num=new intf31; 常 (Exception ),提示'age input error。最后統计该工 保安平均年龄。
时间: 2024-03-16 15:41:26 浏览: 51
您的问题是如何从键盘接收三个保安的年龄,判断是否符合要求,并计算它们的平均年龄。
以下是示例代码,可以实现您的要求:
```java
import java.util.Scanner;
public class Example02 {
public static void main(String[] args) throws Exception {
Scanner input = new Scanner(System.in);
int[] ages = new int[3];
int sum = 0;
for (int i = 0; i < 3; i++) {
System.out.print("请输入第" + (i+1) + "名保安的年龄:");
String ageStr = input.nextLine();
if (ageStr.contains("-")) {
throw new Exception("age input error");
}
int age = Integer.parseInt(ageStr);
if (age > 60 || age < 18) {
throw new Exception("age input error");
}
ages[i] = age;
sum += age;
}
System.out.println("三名保安的平均年龄为:" + sum / 3.0);
}
}
```
代码中使用了 Scanner 类来从键盘读取输入,并使用数组来保存三个保安的年龄。在读取每个年龄时,先判断是否符合要求,如果不符合则抛出异常。最后计算三个年龄的平均值并输出。
阅读全文