2、选做题 函数fun的功能是:将一个无符号整数s的偶数数字取出形成一个新数,构成方式是高位仍在高位,低位仍在低位,将新数作为函数值返回。 函数接口定义:int fun(unsigned int s) 要求:在main函数中输入一个整数,调用fun函数,在main函数中输出结果。 输入样例1: 123456 输出样例1: 246 输入样例2: 2876439 输出样例2: 2864 用C语言写
时间: 2023-06-26 18:07:09 浏览: 143
fun的功能是进行数字字符转换,
5星 · 资源好评率100%
以下是函数fun的代码实现,通过取余运算和位运算实现取出s的偶数数字:
```c
int fun(unsigned int s) {
int res = 0;
int digit = 0;
while (s != 0) {
digit = s % 10; // 取出最低位数字
if (digit % 2 == 0) { // 判断是否为偶数
res = res << 1; // 左移一位,为新数腾出位置
res += digit; // 将偶数数字加入新数的低位
}
s = s / 10; // 去掉最低位数字
}
return res;
}
```
在主函数中调用该函数,并输出结果:
```c
#include <stdio.h>
int fun(unsigned int s);
int main() {
unsigned int s;
scanf("%u", &s);
int res = fun(s);
printf("%d\n", res);
return 0;
}
```
阅读全文