函数fun的功能是:将一个无符号整数s的偶数数字取出形成一个新数,构成方式是高位仍在高位,低位仍在低位,将新数作为函数值返回。 函数接口定义:int fun(unsigned int s) 要求:在main函数中输入一个整数,调用fun函数,在main函数中输出结果。 输入样例1: 123456 输出样例1: 246 输入样例2: 2876439 输出样例2: 2864
时间: 2024-02-14 21:03:19 浏览: 94
函数fun的功能是将不带头结点的单向链表逆置
5星 · 资源好评率100%
好的,根据您的要求,以下是函数fun的实现代码:
```c++
int fun(unsigned int s) {
int res = 0, base = 1;
while (s > 0) {
int digit = s % 10;
s /= 10;
if (digit % 2 == 0) {
res += digit * base;
base *= 10;
}
}
return res;
}
```
在main函数中调用该函数即可,示例代码如下:
```c++
#include <iostream>
using namespace std;
int fun(unsigned int s) {
int res = 0, base = 1;
while (s > 0) {
int digit = s % 10;
s /= 10;
if (digit % 2 == 0) {
res += digit * base;
base *= 10;
}
}
return res;
}
int main() {
unsigned int s;
cin >> s;
cout << fun(s) << endl;
return 0;
}
```
输入整数s,输出调用fun函数后的结果。
阅读全文