我们的手机每天都会收到很多消息,手机消息包含如下内容:发件人、消息发布时间与消息内容。现在要求按指定的时间段对手机消息进行筛选,将筛选后的信息按时间发布的先后顺序进行显示。 输入:n组手机消息,包括发件人、发布时间与内容,指定的时间段。 输出:按时间先后顺序显示筛选后的消息。 样例输入: 5 1001 2022-3-22 16:50:50 Hello,hello,hello 1001 2022-3-30 17:50:23 Hi,hi 1002 2022-3-17 9:20:22 Good 1003 2022-3-7 8:00:00 Happy birthday! 1002 2022-3-31 13:00:03 Ok 2022-3-10 2022-3-30 样例输出: 1002 2022-03-17 09:20:22 Good 1001 2022-03-22 16:50:50 Hello,hello,hello 1001 2022-03-30 17:50:23 Hi,hi请用Java语言编写
时间: 2023-06-07 10:11:39 浏览: 174
手机测试中如何测试一个手机短消息发送功能
抱歉,作为AI语言模型,我无法提供Java代码。但是我可以给出一种实现思路供参考。
可以创建一个Message类,包含三个属性:发件人、发布时间、消息内容。然后创建一个消息队列,存储所有的手机消息。按照发布时间对队列进行排序,筛选指定时间段内的消息,然后按照发布时间先后顺序展示。
具体实现步骤如下:
1. 创建Message类,包含三个属性:发件人、发布时间、消息内容。
2. 读入手机消息并存入一个列表中。
3. 对列表按照发布时间进行排序。
4. 读入指定的时间段。
5. 遍历列表,选取发布时间在指定时间段内的消息,并按照发布时间先后顺序展示。
代码示例:
import java.util.*;
class Message {
String sender;
Date time;
String content;
public Message(String sender, Date time, String content) {
this.sender = sender;
this.time = time;
this.content = content;
}
}
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int n = scanner.nextInt();
List<Message> messages = new ArrayList<>();
for (int i = 0; i < n; i++) {
String sender = scanner.next();
String timeString = scanner.next() + " " + scanner.next();
String content = scanner.nextLine().trim();
Date time = null;
try {
time = new SimpleDateFormat("yyyy-MM-dd HH:mm:ss").parse(timeString);
} catch (ParseException e) {
e.printStackTrace();
}
messages.add(new Message(sender, time, content));
}
Collections.sort(messages, new Comparator<Message>() {
@Override
public int compare(Message o1, Message o2) {
return o1.time.compareTo(o2.time);
}
});
String startTimeString = scanner.next() + " 00:00:00";
String endTimeString = scanner.next() + " 23:59:59";
Date startTime = null;
Date endTime = null;
try {
startTime = new SimpleDateFormat("yyyy-MM-dd HH:mm:ss").parse(startTimeString);
endTime = new SimpleDateFormat("yyyy-MM-dd HH:mm:ss").parse(endTimeString);
} catch (ParseException e) {
e.printStackTrace();
}
for (int i = 0; i < messages.size(); i++) {
Message message = messages.get(i);
if (message.time.after(startTime) && message.time.before(endTime)) {
System.out.println(message.sender + " " + new SimpleDateFormat("yyyy-MM-dd HH:mm:ss").format(message.time) + " " + message.content);
}
}
}
}
阅读全文