本题要求编写程序,根据输入学生的成绩,统计并输出学生的平均成绩、最高成绩和最低成绩。建议使用动态内存分配来实现。 输入格式: 输入第一行首先给出一个正整数N,表示学生的个数。接下来一行给出N个学生的成绩,数字间以空格分隔。 输出格式: 按照以下格式输出: average = 平均成绩 max = 最高成绩 min = 最低成绩 结果均保留两位小数。 输入样例: 3 85 90 95 输出样例: average = 90.00 max = 95.00 min = 85.00
时间: 2023-06-20 19:05:54 浏览: 74
pta输出学生成绩.docx
以下是C++的代码实现。
```cpp
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
int n;
cin >> n;
double* scores = new double[n]; // 动态分配数组
double sum = 0;
for (int i = 0; i < n; i++) {
cin >> scores[i];
sum += scores[i];
}
double average = sum / n;
double max_score = scores[0], min_score = scores[0];
for (int i = 1; i < n; i++) {
if (scores[i] > max_score) {
max_score = scores[i];
}
if (scores[i] < min_score) {
min_score = scores[i];
}
}
cout << "average = " << fixed << setprecision(2) << average << endl;
cout << "max = " << fixed << setprecision(2) << max_score << endl;
cout << "min = " << fixed << setprecision(2) << min_score << endl;
delete[] scores; // 释放动态分配的数组
return 0;
}
```
阅读全文