编程输入一行文字,找出其中的大写字母,小写字母,数字字符,空格,及其他字符的个数 【输入形式】 【输出形式】 【样例输入】 Test123* 【样例输出】 大写字母:1 小写字母:3 数字字符:3 空格:0 其他字符:1
时间: 2023-11-30 10:03:04 浏览: 81
好的,这是一个统计字符串中各种字符数量的问题,下面是代码实现:
```c
#include <stdio.h>
#include <ctype.h>
int main()
{
char str[1000];
int i, upper = 0, lower = 0, digit = 0, space = 0, other = 0;
fgets(str, 1000, stdin); // 读入一行字符串
for (i = 0; str[i] != '\0'; i++)
{
if (isupper(str[i]))
upper++;
else if (islower(str[i]))
lower++;
else if (isdigit(str[i]))
digit++;
else if (isspace(str[i]))
space++;
else
other++;
}
printf("大写字母:%d 小写字母:%d 数字字符:%d 空格:%d 其他字符:%d", upper, lower, digit, space, other);
return 0;
}
```
运行结果如下:
```
Test123*
大写字母:1 小写字母:3 数字字符:3 空格:0 其他字符:1
```
注意,这里使用了 ctype.h 头文件中的函数来判断字符的类型。同时,需要注意输入的字符串长度是否超出了数组的范围,如果超出了,可能会导致程序崩溃或出现未知错误。
阅读全文