c语言 题目描述 用指针实现:输入一行文字,找出其中大写字母、小写字母、空格、数字以及其他字符各有多少。 输入 一行英文字符串(长度不超过200)。 输出 统计其中的英文大写字母、小写字母、空格、数字以及其他字符的个数。 样例输入 When I was 5 years old, Beijing held the 2008 Olympic Games. 样例输出 大写字母:5 小写字母:37 空格:11 数字:5 其他字符:2
时间: 2024-02-25 11:54:38 浏览: 121
C语言程序设计-输入一行字符,分别统计出英文大小写字母、空格、数字和其他字符的个数
5星 · 资源好评率100%
好的,这是一道 c 语言的编程题目,我会尽力帮助你解决问题。
你可以参考下面的代码实现:
```c
#include <stdio.h>
#include <ctype.h>
#define MAX_LEN 200
int main() {
char str[MAX_LEN];
int upper_count = 0, lower_count = 0, space_count = 0, digit_count = 0, other_count = 0;
fgets(str, MAX_LEN, stdin);
for (int i = 0; str[i] != '\0'; i++) {
if (isupper(str[i])) {
upper_count++;
} else if (islower(str[i])) {
lower_count++;
} else if (isspace(str[i])) {
space_count++;
} else if (isdigit(str[i])) {
digit_count++;
} else {
other_count++;
}
}
printf("大写字母:%d 小写字母:%d 空格:%d 数字:%d 其他字符:%d\n", upper_count, lower_count, space_count, digit_count, other_count);
return 0;
}
```
程序中使用了 `isupper`、`islower`、`isspace` 和 `isdigit` 函数来判断字符的类型,分别表示是否为大写字母、小写字母、空格和数字。如果不属于这些类型,则被认为是其他字符。
在 `main` 函数中,我们先从输入中读取字符串,然后遍历字符串,统计出各类字符的个数,并最终输出结果。
如果你有任何问题,都可以随时问我哦!
阅读全文