为了方便喵星市民的出行,喵星建立了连通N个城市的高铁路线,其中第i个高铁站以所在的城市S命名。 为了照顾赶时间的乘客,除了每站都会停靠的普快列车,高铁还开设了特快列车,与普快不同的是,特快列车只会停靠在路线中的M个车站, 其中第i个停靠的站点为Ti,且特快的始发站和终点站Tl,Tm依次为S1,SN。 站长小喵正在编写特快停靠的旅客提示牌,对于每个站点,请你协助小喵判断特快列车是否会在此处停靠。 输入格式: 共三行: 第一行两个整数N,M,依次表示高铁路线的站点数和特快列车的停靠数; 第二行N个字符串Si,依次表示第i个站点的名称; 第三行M个字符串Ti,依次表示特快列车停靠的站点名称。 输出格式: N行,每行一个字符串,若特快列车停靠在第i个车站,第i行输出Yes,否则输出No 样例输入1: 5 3 beijing shanghai shenzhen nanjing guangzhou beijing shenzhen guangzhou 样例输出1: Yes No Yes No Yes 样例输入2: 7 7 a b c d e f g a b c d e f g 样例输出2: Yes Yes Yes Yes Yes Yes Yes。c++解决
时间: 2024-02-12 15:07:19 浏览: 117
以下是 C++ 代码示例,实现了你所需要的功能:
```cpp
#include <iostream>
#include <string>
#include <unordered_set>
using namespace std;
int main() {
int n, m;
cin >> n >> m;
unordered_set<string> stop_stations;
for (int i = 0; i < m; i++) {
string station;
cin >> station;
stop_stations.insert(station);
}
for (int i = 0; i < n; i++) {
string station;
cin >> station;
if (stop_stations.count(station) > 0) {
cout << "Yes" << endl;
} else {
cout << "No" << endl;
}
}
return 0;
}
```
该程序使用了 `std::unordered_set` 来存储特快列车停靠的站点名称,然后遍历所有站点,判断该站点是否属于特快列车停靠的站点集合,最终输出 Yes 或 No。
注意,为了使用 `std::unordered_set`,需要在代码开头添加 `#include <unordered_set>` 头文件。
阅读全文