请用C语言编写如下程序:定义一个80个元素的字符数组,输入一串字符存放其中,统计每个数字字符的个数按数字字符的顺序存放在 int c[10]的数组中。并输出结果。【输入样例】 abc123450987JFK012【输出样例】 0:2(字符串中含有2个0) 1:2 2:2 3:1 4:1 5:1 6:0 7:1 8:1 9:1
时间: 2023-06-08 15:04:48 浏览: 77
编写程序,要求统计任意字符串中数字字符,字母和其他字符的个数
4星 · 用户满意度95%
以下是用C语言编写的程序:
#include <stdio.h>
int main()
{
char str[80];
int c[10] = {0}; // 初始化数组c
printf("请输入一串字符串:");
scanf("%s", str);
// 统计每个数字字符的个数
for (int i = 0; str[i] != '\0'; i++)
{
if (str[i] >= '0' && str[i] <= '9')
{
c[str[i] - '0']++;
}
}
// 按数字字符的顺序输出结果
for (int i = 0; i < 10; i++)
{
printf("%d:%d", i, c[i]);
if (c[i] != 0)
{
printf("(字符串中含有%d个%d)", c[i], i);
}
printf("\n");
}
return 0;
}
输出结果:
请输入一串字符串:abc123450987JFK012
0:2(字符串中含有2个0)
1:2(字符串中含有2个1)
2:2(字符串中含有2个2)
3:1(字符串中含有1个3)
4:1(字符串中含有1个4)
5:1(字符串中含有1个5)
6:0
7:1(字符串中含有1个7)
8:1(字符串中含有1个8)
9:1(字符串中含有1个9)
阅读全文