输入string字符串str(可以包含空格字符),替换把其中的字符'c'替换成'C'。 int main(){ string str; //补充输入 Replace(str, 'c', 'C'); cout << str << endl; return 0; 输入 字符串 输出 结果 输入样例 1 abcdedgc 输出样例 1 abCdedgC
时间: 2024-03-10 16:46:06 浏览: 111
c语言实现字符串替换
5星 · 资源好评率100%
可以使用string类的replace函数来实现替换,具体代码如下:
```
#include <iostream>
#include <string>
using namespace std;
void Replace(string& str, char c1, char c2) {
for (int i = 0; i < str.length(); i++) {
if (str[i] == c1) {
str.replace(i, 1, 1, c2);
}
}
}
int main() {
string str;
getline(cin, str); // 使用getline函数读取包含空格的字符串
Replace(str, 'c', 'C');
cout << str << endl;
return 0;
}
```
输入样例:
```
abcdedgc
```
输出样例:
```
abCdedgC
```
阅读全文