编写JAVA代码,输入一个整数N求阶乘
时间: 2024-03-20 13:44:42 浏览: 63
好的,您可以参考以下JAVA代码实现N的阶乘计算:
```java
import java.util.Scanner;
public class Factorial {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
System.out.print("请输入一个整数N:");
int n = input.nextInt();
int result = 1;
for (int i = 1; i <= n; i++) {
result *= i;
}
System.out.printf("%d! = %d\n", n, result);
}
}
```
您只需要在命令行或者集成开发环境中运行该JAVA程序,输入一个整数N,程序即可计算并输出N的阶乘。
相关问题
java定义一个求阶乘的函数fact(n),并编写测试代码,要求输入整数n(n>=0)。 输入示例 5 输出示例 5! = 120
在Java中,你可以定义一个静态方法`factorial`来计算阶乘,然后在主程序中提供一个简单的测试用例。下面是一个如何定义和测试阶乘函数的例子:
```java
public class FactorialCalculator {
// 静态方法,计算阶乘
public static long factorial(int n) {
if (n < 0) {
throw new IllegalArgumentException("Input must be non-negative.");
}
long result = 1;
for (int i = 1; i <= n; i++) {
result *= i;
}
return result;
}
public static void main(String[] args) {
int input = 5; // 测试用例
try {
long output = factorial(input);
System.out.printf("%d! = %d\n", input, output);
} catch (IllegalArgumentException e) {
System.out.println(e.getMessage());
}
}
}
```
在这个例子中,`factorial`函数首先检查输入是否非负,然后通过循环逐个相乘计算阶乘。在`main`方法中,我们调用这个函数,并打印出结果。如果输入无效,会捕获到异常并显示相应的错误信息。
用Java编写应用程序,输出一个输入整数n的阶乘。
在Java中,你可以使用递归或循环来计算一个整数n的阶乘。这里是一个简单的例子,展示了如何使用循环实现:
```java
import java.util.Scanner;
public class Factorial {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
System.out.print("请输入一个整数:");
int n = scanner.nextInt();
long factorial = calculateFactorial(n);
System.out.printf("数字 %d 的阶乘是 %d\n", n, factorial);
}
// 使用循环计算阶乘
private static long calculateFactorial(int num) {
if (num == 0 || num == 1) {
return 1;
} else {
long result = 1;
for (int i = 2; i <= num; i++) {
result *= i;
}
return result;
}
}
}
```
在这个程序中,`calculateFactorial`函数接收一个整数`num`作为参数,并通过循环逐个相乘来计算阶乘。如果输入的是0或1,则直接返回1(因为0!和1!都等于1)。
阅读全文