LC-3,汇编语言,目的:执行完成之后输出ABCFGH。帮我补充问号未知的指令,每个问号只有一条指令 . ORIG x3000 LEA R1,TESTOUT BACK_1 LER R0,R1,#0 BRz NEXT_1 TRAP x21 ADD R1,R1,#1 BRnzp BACK_1 NEXT_1 LEA R1,TESTOUT BACK_2 LDR R0,R1,#0 BRz NEXT_2 JSR SUB_1 ADD R1,R1,#1 BRnzp BACK_2 NEXT_2 ? SUB_1 ? K LDI R2,DSR ? STI R0,DDR RET DSR .FILL xFE04 DDR .FILL xFE06 TESTOUT .STRINGZ "ABC" .END
时间: 2024-01-12 11:02:28 浏览: 77
下面是补充问号的指令:
```
SUB_1 ADD R0,R0,K
RET
K .FILL #70
LD R0,TESTOUT+1
```
注:补充的指令中,第一行是 `SUB_1` 标签下的指令,第二行是 `K` 标签下的指令,第三行是 `LD` 指令,用于将 `TESTOUT` 标签指向的字符串 "ABC" 的第二个字符(即字符 B)加载到寄存器 R0 中。
相关问题
题目:通配符查找。 从键盘输入两个字符串。第一个字符串命名为mstr第二个字符 串命名为fstr。在fstr的中间(非首字符 非末字符)包含一个'’, 该字符常作为通配符,即代表一个或多个字符。 现请编写程序,查找mstr中是否包含fstr,若包含则输出找到 的所有子串。
输入格式:
两个字符串,每个字符串占一行。
输出格式:
若包含,则输出所有子串,每个子串占一行;否则输出"Not Found"。
输入样例:
abcdefgh
abc*fgh
输出样例:
abcde
abcdef
abc*fgh
abcdfgh
abcfgh
使用C++进行编程,输入为两个由单链表组成的字符串x和y,(其中每个结点只存储一个字符),请编写一个算法,找出x中第一个不在y中出现的字符。
思路:
首先,我们需要遍历链表x中的每个字符,并逐个检查它是否存在于链表y中。为了减少时间复杂度,我们可以使用一个哈希表来存储链表y中的字符,并在遍历链表x时进行查找。如果找到了一个不在哈希表中的字符,就返回它。
代码实现如下:
```c
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define TABLE_SIZE 128
typedef struct Node {
char data;
struct Node* next;
} Node;
Node* createList(char* str) {
Node* head = NULL;
Node* tail = NULL;
int len = strlen(str);
for (int i = 0; i < len; i++) {
Node* node = (Node*)malloc(sizeof(Node));
node->data = str[i];
node->next = NULL;
if (tail) {
tail->next = node;
} else {
head = node;
}
tail = node;
}
return head;
}
char findFirstMissingChar(Node* x, Node* y) {
int table[TABLE_SIZE] = {0};
Node* p = y;
while (p) {
table[p->data] = 1;
p = p->next;
}
p = x;
while (p) {
if (table[p->data] == 0) {
return p->data;
}
p = p->next;
}
return '\0';
}
int main() {
char str1[100], str2[100];
printf("Please enter two strings:\n");
scanf("%s%s", str1, str2);
Node* x = createList(str1);
Node* y = createList(str2);
char c = findFirstMissingChar(x, y);
if (c) {
printf("The first missing char is: %c\n", c);
} else {
printf("All chars in x are in y.\n");
}
return 0;
}
```
测试:
输入:
```
abcde
abcfgh
```
输出:
```
The first missing char is: d
```
阅读全文