编写自定义函数fact(s)统计字符串s中数字字符的个数并返回,键盘输入一个字符串,调用函数fact(),统计该字符串中数字字符的个数并输出
时间: 2024-05-27 21:11:25 浏览: 91
def fact(s):
count = 0
for char in s:
if char.isdigit():
count += 1
return count
s = input("请输入一个字符串:")
print("该字符串中数字字符的个数为:" + str(fact(s)))
相关问题
编写自定义函数fact(s)统计字符串s中数字字符的个数并返回,键盘输入一个字符串,调用函数fact(),统计该字符串中数字字符的个数并输出。,
def fact(s):
count = 0
for c in s:
if c.isdigit():
count += 1
return count
s = input("请输入一个字符串:")
num_count = fact(s)
print("该字符串中数字字符的个数为:", num_count)
c语言从键盘输入一个字符串,统计字符串中大写字母的个数,要求统计大写字母的个数用自定义函数实现。 只编写大写字母字符统计的自定义函数 int fact(char str[])程序。 主函数如下 #include<stdio.h> int main() { int res; char s[50]; gets(s); res=fact(s); printf("%d",res); return 0; } 输入格式: 输入一个字符串(长度不超过49个字符) 输出格式: 以整型格式输出结果 输入样例: Hello World! 输出样例: 2
好的,我知道了。下面是符合要求的代码:
```
#include <stdio.h>
int fact(char str[]) {
int count = 0;
for(int i = 0; str[i] != '\0'; i++) {
if(str[i] >= 'A' && str[i] <= 'Z') {
count++;
}
}
return count;
}
int main() {
int res;
char s[50];
gets(s);
res = fact(s);
printf("%d", res);
return 0;
}
```
这个程序中,`fact` 函数用于统计大写字母的个数。它遍历整个字符串,如果当前字符是大写字母,就将计数器加1。最终返回计数器的值。在 `main` 函数中,我们调用 `fact` 函数统计大写字母的个数,并将结果打印出来。
需要注意的是,`gets` 函数已经不建议使用了,因为它存在安全漏洞。可以使用 `fgets` 函数代替。同时,在 `fact` 函数中,我们使用了字符数组的遍历方式来遍历字符串。这种方式适用于 C 语言中的字符串操作,但是需要注意字符串的结尾符 `\0`。
阅读全文