编写c++,输入一行字符串,统计字符串中字符的个数
时间: 2023-07-16 15:17:22 浏览: 641
以下是使用C++标准库的方法来实现输入一行字符串并统计字符个数的代码:
```c++
#include <iostream>
#include <string>
using namespace std;
int main() {
string str;
int count = 0;
cout << "请输入一行字符串:";
getline(cin, str); // 读取一行字符串
for (char c : str) { // 遍历字符串的每个字符
count++;
}
cout << "字符串中字符的个数为:" << count << endl;
return 0;
}
```
在上面的代码中,我们使用 `string` 类型来存储输入的一行字符串,并使用 `getline()` 函数来读取一行字符串(包括空格),然后使用 `for` 循环遍历字符串的每个字符,并将计数器 `count` 加一。最后输出统计结果即可。
相关问题
c++编写程序输入一行字符串,统计其中英文字符、数字、空格及其他字符的个数,
可以使用C++中的字符处理函数`isalpha()`、`isdigit()`和`isspace()`来判断字符类型,然后遍历字符串进行统计。
以下是示例代码:
```c++
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
char str[100];
int alphaCount = 0, digitCount = 0, spaceCount = 0, otherCount = 0;
cout << "请输入一个字符串:" << endl;
cin.getline(str, 100);
for(int i = 0; i < strlen(str); i++)
{
if(isalpha(str[i])) alphaCount++;
else if(isdigit(str[i])) digitCount++;
else if(isspace(str[i])) spaceCount++;
else otherCount++;
}
cout << "字母个数:" << alphaCount << endl;
cout << "数字个数:" << digitCount << endl;
cout << "空格个数:" << spaceCount << endl;
cout << "其他字符个数:" << otherCount << endl;
return 0;
}
```
输入示例:`Hello World! 233`
输出示例:
```
请输入一个字符串:
Hello World! 233
字母个数:10
数字个数:3
空格个数:2
其他字符个数:1
```
C++编写任意输入一个字符串统计其中字母a与字母i的个数
你好啊!关于你的问题,我可以帮你。以下是C语言的代码,可以统计输入字符串中字母a和字母i的个数:
```
#include <stdio.h>
int main() {
char str[100];
int a_count = 0, i_count = 0;
printf("请输入字符串:");
scanf("%s", str);
for(int i = 0; str[i] != '\0'; i++) {
if(str[i] == 'a' || str[i] == 'A') {
a_count++;
} else if(str[i] == 'i' || str[i] == 'I') {
i_count++;
}
}
printf("字符串中字母a的个数是:%d\n", a_count);
printf("字符串中字母i的个数是:%d\n", i_count);
return 0;
}
```
希望这个回答可以帮到你。还有什么其他问题吗?
阅读全文