本题要求实现一个函数,遍历一个不带头结点的链表,求链表节点数据的累加和 节点类型定义: struct node { int ch ; struct node *next ;} 函数接口定义: int sum_node( struct node *p) p是链表头指针,返回链表上所有节点ch属性值的累加和。 裁判测试程序样例: #include <stdio.h> #include<stdlib.h> struct node {int ch; struct node * next;}; struct node *setlink(int N);//建链表函数已经定义 int sum_node(struct node * head);//需要定义的函数 int main() { int N; struct node *head; scanf("%d",&N); head=setlink(N); printf("%d", sum_node(head)); return 0; } /* 请在这里填写答案 */ 输入样例: 在这里给出一组输入。例如: 6 3 1 2 7 4 5 输出样例: 在这里给出相应的输出。例如: 22
时间: 2024-04-13 21:30:55 浏览: 102
你可以使用以下代码实现这个函数:
```c
#include <stdio.h>
#include <stdlib.h>
struct node {
int ch;
struct node *next;
};
int sum_node(struct node *head) {
int sum = 0; // 初始化累加和为0
struct node *current = head;
while (current != NULL) {
sum += current->ch; // 累加当前节点的值
current = current->next; // 移动到下一个节点
}
return sum;
}
// 测试代码
struct node *setlink(int N) {
struct node *head = NULL;
struct node *prev = NULL;
for (int i = 0; i < N; i++) {
struct node *newNode = (struct node *)malloc(sizeof(struct node));
scanf("%d", &(newNode->ch));
newNode->next = NULL;
if (head == NULL) {
head = newNode;
} else {
prev->next = newNode;
}
prev = newNode;
}
return head;
}
int main() {
int N;
struct node *head;
scanf("%d", &N);
head = setlink(N);
printf("%d", sum_node(head));
return 0;
}
```
这段代码首先定义了一个节点结构体 `node`,包含一个整数属性 `ch` 和一个指向下一个节点的指针 `next`。
然后是 `sum_node` 函数,它接收一个链表的头指针 `head`,并返回链表节点数据的累加和。函数使用一个变量 `sum` 来记录累加和,初始值为0。然后使用一个循环遍历链表的每个节点,将节点的值累加到 `sum` 中。最后返回 `sum`。
为了测试这个函数,提供了一个 `setlink` 函数来构建链表。它接收一个整数 `N`,表示链表的长度,然后从输入中读取 `N` 个整数,并构建相应的链表。最后在 `main` 函数中调用 `setlink` 函数来创建链表,并调用 `sum_node` 函数来求解累加和,并输出结果。
阅读全文