6-1 计算总分 分数 10 作者 王从银 单位 吉首大学 请编写一个函数sum,函数的功能是:计算一个由结构体表示的包含多门课程成绩组成的学生的总成绩。 函数接口定义: double sumScore(struct student stu); 其中 stu是用户传入的参数。函数须返回学生的总成绩。 裁判测试程序样例: #include <stdio.h> struct student{ int sid; char name[20]; double math; //此数据成员表示数学程成绩 double english; //此数据成员表示英语课程成绩 double program; //此数据成员表示编程课程成绩 }; double sum(struct student st); int main(){ struct student st; scanf("%d%s%lf%lf%lf",&st.sid, st.name, &st.math, &st.english, &st.program); printf("%.2f\n",sum(st)); return 0; } /* 请在这里填写答案 */ 输入样例: 1000 xiaopeng 90 90 90 输出样例: 270.00 代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MC语言
时间: 2024-01-07 17:05:46 浏览: 115
本题需要计算一个学生的总成绩,所以我们需要将该学生各科目的成绩相加。可以编写如下的函数实现:
```c
double sumScore(struct student stu) {
return stu.math + stu.english + stu.program;
}
```
其中,`stu.math`、`stu.english` 和 `stu.program` 分别表示数学、英语和编程课程的成绩。函数返回这三个成绩的和。
完整代码如下:
```c
#include <stdio.h>
struct student {
int sid;
char name[20];
double math; // 数学成绩
double english; // 英语成绩
double program; // 编程成绩
};
double sumScore(struct student stu) {
return stu.math + stu.english + stu.program;
}
int main() {
struct student st;
scanf("%d%s%lf%lf%lf", &st.sid, st.name, &st.math, &st.english, &st.program);
printf("%.2f\n", sumScore(st));
return 0;
}
```
阅读全文