C语言程序设计-输入一行字符,分别统计出英文大小写字母、空格、数字和其他字符的个数 【样例输入】ewrAA 112*&^% 【样例输出】upper: 2 lower: 3 blank: 1 digit: 3 other: 4
时间: 2024-11-29 20:38:44 浏览: 69
在C语言中,你可以使用`ctype.h`库中的函数来判断每个字符的类别,然后遍历输入的字符串进行计数。以下是一个简单的示例程序,它会接受用户输入的一行字符,并计算大写字母、小写字母、空格、数字以及其他特殊字符的数量:
```c
#include <stdio.h>
#include <ctype.h>
int main() {
char input[100];
int upper = 0, lower = 0, space = 0, digit = 0, other = 0;
printf("请输入一行字符: ");
fgets(input, sizeof(input), stdin); // 注意 fgets 会在末尾添加 '\n'
for (int i = 0; input[i] != '\0'; i++) {
if (isupper(input[i])) {
upper++;
} else if (islower(input[i])) {
lower++;
} else if (isspace(input[i])) {
space++;
} else if (isdigit(input[i])) {
digit++;
} else { // 其他字符
other++;
}
}
printf("upper: %d lower: %d blank: %d digit: %d other: %d\n",
upper, lower, space, digit, other);
return 0;
}
```
当你运行这个程序并输入样例输入 "ewrAA 112*&^%" 时,它将输出:
```
upper: 2 lower: 3 blank: 1 digit: 3 other: 4
```
阅读全文