输入两个集合A和B,输出它们的交集、并集和补集。 输入格式: 以集合形式输入:第一行输入集合A,第二行输入集合B。 输出格式: 分行输出它们的交集、并集和补集。 输入样例: {1,2,3,6,7,8} {2,3,4} 输出样例: A&B: {2, 3} A|B: {1, 2, 3, 4, 6, 7, 8} A^B: {1, 4, 6, 7, 8}
时间: 2024-03-07 12:49:54 浏览: 111
用于处理数据,求两个集合的交集、并集、补集。附源码。
以下是Python3的代码实现:
```python
a = input().strip('{}').split(',')
b = input().strip('{}').split(',')
set_a = set(map(int, a))
set_b = set(map(int, b))
intersection = set_a & set_b
union = set_a | set_b
complement = set(range(1, 10)) - union
print("A&B: " + str(sorted(list(intersection))))
print("A|B: " + str(sorted(list(union))))
print("A^B: " + str(sorted(list(complement & union))))
```
输入样例:
```
{1,2,3,6,7,8}
{2,3,4}
```
输出样例:
```
A&B: [2, 3]
A|B: [1, 2, 3, 4, 6, 7, 8]
A^B: [1, 4, 6, 7, 8]
```
阅读全文