7-3 Detach a three-digit integer 分数 10 作者 李克峰 单位 山东交通学院 Input a three-digit integer, detach its units, tens and hundr.ds, and output them on the screen. Input: Input a three-digit integer. Output: Output the units, tens and hundreds of input in one line, seperated by comma Input sample: 576 Output sample: 5, 7, 6用C语言解决
时间: 2024-03-26 15:38:14 浏览: 128
输入三个整数,按由大到小输出.c
下面是使用 C 语言解决此问题的代码:
```c
#include <stdio.h>
int main() {
int num, units, tens, hundreds;
printf("Input a three-digit integer: ");
scanf("%d", &num);
units = num % 10;
tens = (num / 10) % 10;
hundreds = num / 100;
printf("%d, %d, %d", hundreds, tens, units);
return 0;
}
```
首先,我们声明了四个整型变量:`num` 存储用户输入的数字,`units` 存储个位数,`tens` 存储十位数,`hundreds` 存储百位数。
然后,我们使用 `scanf` 函数从标准输入中读取用户输入的数字,存储在 `num` 变量中。
接着,我们使用 `%` 运算符分别计算出个位数、十位数和百位数,并分别存储在对应的变量中。
最后,我们使用 `printf` 函数将三个数字以逗号分隔的形式输出到屏幕上。
注意,此代码假设用户输入的数字是一个三位数。如果用户输入的数字不是三位数,那么输出的结果可能不正确。因此,在实际应用中,我们应该添加一些输入合法性检查的代码,以确保程序的正确性。
阅读全文