在字符串中删除与某字符相同的字符,要求用字符数组作函数参数。 程序运行结果示例: Input a string: hello, my friend! Input a character: e Results:hllo, my frind! 输入格式: 输入字符串的提示信息: "Input a string:\n" 输入单个字符的提示信息: "Input a character:\n" 输入格式: 字符串输入用 gets()函数 单个字符输入用 getchar()函数 输出格式: "Results:%s\n" 输入样例: 在这里给出一组输入。例如: hello, my friend! e 输出样例: 在这里给出相应的输出。例如: Input a string: Input a character: Results:hllo, my frind! 代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MB C (gcc) Selection deleted 1
时间: 2024-03-13 19:44:03 浏览: 149
C语言程序设计-从字符串中删除指定的字符;同一字母的大、小写 按不同字符处理;
5星 · 资源好评率100%
请看下面的代码实现:
```c
#include <stdio.h>
#include <string.h>
void deleteChar(char str[], char ch) {
int len = strlen(str);
int j = 0;
for (int i = 0; i < len; i++) {
if (str[i] != ch) {
str[j++] = str[i];
}
}
str[j] = '\0';
}
int main() {
char str[1000], ch;
printf("Input a string:\n");
gets(str);
printf("Input a character:\n");
ch = getchar();
deleteChar(str, ch);
printf("Results:%s\n", str);
return 0;
}
```
其中,`deleteChar` 函数用来删除字符串中与指定字符相同的字符,`main` 函数用来输入字符串和指定字符,并输出结果。注意,输入字符串时要用 `gets` 函数,因为 `gets` 函数可以读取一行字符串,包括空格和其他特殊字符;而输入单个字符时要用 `getchar` 函数。另外,在删除字符后要在字符串结尾处添加一个空字符,以表示字符串的结束。
阅读全文