C语言代码【问题描述】 创建一个哈希表,构造方法使用“除留余数法”,并使用开放定址法来避免哈希冲突。编写查找函数完成以下功能: Status searchHash(HashTable hash, int key, int *addr) { } 【输入形式】 从键盘输入一个key值 【输出形式】 成功则返回该key值的哈希地址,或“查找失败” 【样例输入】 37 【样例输出】 查找37的哈希地址为:2
时间: 2023-12-04 16:02:25 浏览: 183
好的,这是一个关于哈希表的问题,我可以帮你解答。以下是 C 语言代码:
```c
#include <stdio.h>
#include <stdlib.h>
#define SUCCESS 1
#define FAILURE 0
#define EMPTY -1
typedef int Status;
typedef struct{
int *elem;
int count;
int sizeindex;
}HashTable;
int hashsize[] = {3, 7, 11, 19, 29, 37, 47, 59, 71, 89, 107, 131, 163, 197, 239, 293, 353, 431, 521, 631, 761, 919, 1103, 1327, 1597, 1931, 2333, 2801, 3371, 4049, 4861, 5839, 7013, 8419, 10103, 12143, 14591, 17519, 21023, 25229, 30293, 36353, 43627, 52361, 62851, 75431, 90523, 108631, 130363, 156437, 187751, 225307, 270371, 324449, 389357, 467237, 560689, 672827, 807403, 968897, 1162687, 1395263, 1674319, 2009191, 2411033, 2893249, 3471899, 4166287, 4999559, 5999471, 7199369};
Status initHashTable(HashTable *hash, int sizeindex)
{
int i;
hash->sizeindex = sizeindex;
hash->count = hashsize[sizeindex];
hash->elem = (int*)malloc(sizeof(int) * hash->count);
if(!hash->elem)
{
return FAILURE;
}
for(i = 0; i < hash->count; i++)
{
hash->elem[i] = EMPTY;
}
return SUCCESS;
}
int hash(int key, int p)
{
return key % p;
}
Status searchHash(HashTable hash, int key, int *addr)
{
int h, p;
p = hashsize[hash.sizeindex];
h = hash(key, p);
while(hash.elem[h] != EMPTY && hash.elem[h] != key)
{
h = (h + 1) % p;
}
if(hash.elem[h] == key)
{
*addr = h;
return SUCCESS;
}
else
{
return FAILURE;
}
}
int main()
{
HashTable hash;
int key, addr;
printf("请输入key值:");
scanf("%d", &key);
initHashTable(&hash, 0);
if(searchHash(hash, key, &addr) == SUCCESS)
{
printf("查找%d的哈希地址为:%d\n", key, addr);
}
else
{
printf("查找失败\n");
}
return 0;
}
```
以上代码包括了哈希表的初始化、哈希函数、开放定址法解决冲突、查找等功能。你可以根据自己的需求进行修改。
阅读全文