使用c语言编写程序:编写函数,将两个字符串s和t连接起来。s、t的长度均不超过100。不得使用系统库函数。 若s为FirstString--,t为SecondString,则输出结果为FirstString--SecondString。第一行为测试数据的组数T,后跟T组测试数据,每组测试数据包含两行,第一行为字符串s,第二行为字符串t。对于每组测试数据,输出结果单独占一行,为连接后的新字符串。样例输入2 FirstString-- SecondString 123+ 456=579,样例输出FirstString--SecondString 123+456=579
时间: 2024-02-24 18:54:48 浏览: 63
c用c语言编写一个函数,连接两个字符串
4星 · 用户满意度95%
这道题目是之前的题目不小心复制粘贴出了问题。以下是使用 C 语言编写的程序,实现将两个字符串 s 和 t 连接起来的功能:
```c
#include <stdio.h>
void str_concat(char *s, char *t)
{
while (*s != '\0') { // 找到 s 的末尾
s++;
}
while (*t != '\0') { // 将 t 连接到 s 的末尾
*s = *t;
s++;
t++;
}
*s = '\0'; // 结尾字符
}
int main()
{
int T;
scanf("%d", &T); // 输入测试数据组数
while (T--) {
char s[101], t[101];
scanf("%s%s", s, t); // 输入两个字符串
str_concat(s, t); // 将两个字符串连接起来
printf("%s\n", s); // 输出新字符串
}
return 0;
}
```
输入格式为:
```
T
s1
t1
s2
t2
...
```
其中,T 表示测试数据组数,si 和 ti 分别表示两个字符串。输出格式为:
```
s1t1
s2t2
...
```
每个新字符串单独占一行。
阅读全文