定义结构体student,包括学号、姓名、年龄、3门课的成绩和总成绩,输入3名同学的信息,计算每个学生的总成绩并输出。 输入 3个学生的信息,每个学生信息各占一行。 输出 每个学生的学号及总成绩,学号与总成绩之间用空格间隔,每个成绩的输出各占一行。 样例输入 复制 2009001 赵岩 18 86 90 82 2009002 王洋 19 92 88 89 2009003 李玲 18 80 85 79 样例输出 复制 2009001 258 2009002 269 2009003 244
时间: 2024-04-21 21:28:37 浏览: 172
好的,这是一个简单的C语言编程问题,以下是代码实现:
```c
#include <stdio.h>
struct student {
int id;
char name[20];
int age;
int score[3];
int total;
};
int main() {
struct student stu[3];
// 输入学生信息
for (int i = 0; i < 3; i++) {
scanf("%d%s%d%d%d", &stu[i].id, stu[i].name, &stu[i].age, &stu[i].score[0], &stu[i].score[1], &stu[i].score[2]);
stu[i].total = stu[i].score[0] + stu[i].score[1] + stu[i].score[2];
}
// 输出学生总成绩
for (int i = 0; i < 3; i++) {
printf("%d %d\n", stu[i].id, stu[i].total);
}
return 0;
}
```
注意:在输入学生信息时,我们使用了`scanf`函数,它会根据我们指定的格式化字符串,将输入的数据按照对应的类型存储在变量中。同时,在输入完毕后,我们需要计算每个学生的总成绩,存储在结构体的`total`成员变量中。最后,我们按照要求输出每个学生的学号和总成绩即可。
阅读全文