从键盘输入一个三位整数,输出用这个三位整数的各位数字排列出来的最大三位数。如输入345,输出543. Input 输入一个三位整数 Output 输出用这个三位整数的各位数字排列出来的最大三位数 Sample Input 345 Sample Output 543c++代码
时间: 2024-04-10 13:27:51 浏览: 128
下面是一个用C++编写的解决方案:
```cpp
#include <iostream>
#include <algorithm>
#include <string>
int main() {
int num;
std::cin >> num;
// 将整数转换为字符串
std::string numStr = std::to_string(num);
// 对字符串进行排序
std::sort(numStr.begin(), numStr.end(), std::greater<char>());
// 将排序后的字符串转换回整数
int maxNum = std::stoi(numStr);
std::cout << maxNum << std::endl;
return 0;
}
```
在这个例子中,我们首先声明一个变量`num`来存储输入的三位整数。然后,我们使用`std::to_string`将整数转换为字符串。接下来,我们使用`std::sort`对字符串进行排序,通过传入`std::greater<char>()`作为排序函数,以实现按照降序排列。
然后,我们使用`std::stoi`将排序后的字符串转换回整数,得到最大的三位数。
最后,我们使用`std::cout`将最大的三位数输出到标准输出流中。
通过运行这段代码,并给定示例输入`345`,将会得到输出:
```
543
```
希望这可以帮助到您!如果您有任何其他问题,请随时提问。
阅读全文