编写函数myStrcpy,实现字符串复制的功能。(10分) 题目内容: 以下为myStrcpy的函数原型,功能为从source数组复制字符串到dest数组,并返回字符串的长度。在主函数中由用户输入一个字符串,调用该函数,输出复制后的字符串,并输出字符串的长度。 int myStrcpy(char source[],char dest[]); 输入格式: 一行字符,不超过20个字符。 输出格式: 共2行,一行为复制以后的字符串,一行为复制字符串的长度。 输入样例: this is a test. 输出样例: this is a test. 15用C语言编写代码
时间: 2023-06-18 16:05:43 浏览: 103
第8章 指针-6从函数返回字符串1
```c
#include <stdio.h>
int myStrcpy(char source[], char dest[]) {
int i = 0;
while (source[i] != '\0') {
dest[i] = source[i];
i++;
}
dest[i] = '\0';
return i;
}
int main() {
char source[20];
char dest[20];
scanf("%s", source);
int len = myStrcpy(source, dest);
printf("%s\n%d", dest, len);
return 0;
}
```
阅读全文