用C语言编写代码。题目描述(线性表)设键盘输入n个英语单词,输入格式为n, w1, w2, …,wn,其中n表示随后输入英语单词个数,试编一程序,建立一个单向链表,实现:如果单词重复出现,则只在链表上保留一个。 样例输入4 now come now please 样例输出 now come please
时间: 2024-03-02 11:48:28 浏览: 93
好的,这是一个比较基础的线性表题目,以下是用 C 语言编写的代码实现:
```c
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
// 定义链表结点
typedef struct node {
char data[100]; // 存储单词
struct node *next; // 指向下一个结点的指针
} Node;
// 定义链表头指针
Node *head;
// 查找链表中是否已经存在该单词
int search(char *word) {
Node *p = head;
while (p != NULL) {
if (strcmp(p->data, word) == 0) {
return 1; // 存在该单词
}
p = p->next;
}
return 0; // 不存在该单词
}
// 在链表尾部插入新结点
void insert(char *word) {
Node *p = head;
while (p->next != NULL) {
p = p->next;
}
Node *newNode = (Node*)malloc(sizeof(Node));
strcpy(newNode->data, word);
newNode->next = NULL;
p->next = newNode;
}
int main() {
int n;
scanf("%d", &n);
head = (Node*)malloc(sizeof(Node)); // 创建链表头结点
scanf("%s", head->data);
head->next = NULL;
for (int i = 1; i < n; i++) {
char word[100];
scanf("%s", word);
if (!search(word)) { // 如果单词不存在,则插入新结点
insert(word);
}
}
// 输出链表中的单词
Node *p = head;
while (p != NULL) {
printf("%s ", p->data);
p = p->next;
}
return 0;
}
```
这个代码通过输入单词的个数和单词内容,利用链表的结构来保证链表中不存在重复单词,最后输出链表中的单词。
阅读全文