编写一段c语言代码,要求如下输入n个朋友的信息,包括姓名、生日、电话号码,本题要求编写程序,按照年龄从大到小的顺序依次输出通讯录。题目保证所有人的生日均不相同。 输入格式: 输入第一行给出正整数n(<10)。随后n行,每行按照“姓名 生日 电话号码”的格式给出一位朋友的信息,其中“姓名”是长度不超过10的英文字母组成的字符串,“生日”是yyyymmdd格式的日期,“电话号码”是不超过17位的数字及+、-组成的字符串。 输出格式: 按照年龄从大到小输出朋友的信息,格式同输出。 输入样例: 3 zhang 19850403 13912345678 wang 19821020 +86-0571-88018448 qian 19840619 13609876543 输出样例: wang 19821020 +86-0571-88018448 qian 19840619 13609876543 zhang 19850403 13912345678
时间: 2024-02-01 12:12:35 浏览: 121
```c
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX_N 10
#define MAX_NAME_LEN 11
#define MAX_PHONE_LEN 18
struct Friend {
char name[MAX_NAME_LEN];
char birthday[9];
char phone[MAX_PHONE_LEN];
int age;
};
int compare_friend(const void *a, const void *b) {
const struct Friend *f1 = (const struct Friend *)a;
const struct Friend *f2 = (const struct Friend *)b;
return f2->age - f1->age;
}
int calculate_age(const char *birthday) {
int year = (birthday[0] - '0') * 1000 + (birthday[1] - '0') * 100 + (birthday[2] - '0') * 10 + (birthday[3] - '0');
int month = (birthday[4] - '0') * 10 + (birthday[5] - '0');
int day = (birthday[6] - '0') * 10 + (birthday[7] - '0');
return 2021 - year - (month > 9 || (month == 9 && day > 1));
}
int main() {
int n;
struct Friend friends[MAX_N];
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%s %s %s", friends[i].name, friends[i].birthday, friends[i].phone);
friends[i].age = calculate_age(friends[i].birthday);
}
qsort(friends, n, sizeof(struct Friend), compare_friend);
for (int i = 0; i < n; i++) {
printf("%s %s %s\n", friends[i].name, friends[i].birthday, friends[i].phone);
}
return 0;
}
```
阅读全文